Support Center


Lost or forgot your Unlock Code?


While Renewed Vision is NOT responsible for keeping track of an organization's codes,
we'll certainly try to help you find it or get it updated with new information.


Latest Updates
Jul
7
macOS Sierra and iOS 10 beta information
Posted by Renewed Vision on July 07, 2016 at 03:16 PM

macOS Sierra and iOS 10 public betas are not supported for any of our products. Please don't call, email, or send us a tweet if you're using the beta and something doesn't work. We've setup some forum threads for discussing the beta and any issues you run into if you do decide to upgrade. Your reports will help us prepare for the official releases of the new operating systems. If you do report a bug, try to confirm the issue only occurs in the new betas by testing the same steps in the current versions on another Mac or iOS device first.

ProPresenter 5 is only supported through OS X 10.10. However, we have created a discussion thread for anyone who wants to try it out, but we will not be updating ProPresenter 5 to support macOS Sierra.

It's also important to remember that many third-party device drivers may be slow in updating. If you are using a Matrox DualHead or TripleHead, it may not work at all. The same goes for the USB display adapter used for stage display.

Here are the links to the forum threads. Please keep any discussion about the betas in these threads.

ProPresenter 6 discussion/info

ProPresenter 5 discussion/info

ProVideoPlayer 2 discussion/info

ProVideoServer discussion/info

ProRemote discussion/info

Stage Display app discussion/info


Read more »



May
24
ProPresenter 5 and OS X El Capitan (10.11) compatibility issues
Posted by Renewed Vision on May 24, 2016 at 09:11 PM

We are aware of issues with ProPresenter 5 and OS X 10.11.5 and 10.11.6, the latest update to El Capitan. ProPresenter 5 is only supported through OS X 10.10, Yosemite. The latest update to El Capitan appears to cause some kind of an issue with one or more user data files in ProPresenter 5. We have provided instructions for fixing this based on what we have found to work for some of our users. You can find these instructions in our user forums by clicking on this link.


Read more »



May
23
ProPresenter 6 now supports NewTek NDI for IP-based production workflows
Posted by Renewed Vision on May 23, 2016 at 02:25 PM

The latest releases for ProPresenter 6 on Mac (available today) and Windows (coming soon) now include support for NewTek NDI IP-based production workflow. NDI allows you to connect your Mac or PC via a network cable to compatible video hardware.

NDI is part of the SDI Module, which can be purchased for $99 or as part of the Alpha Keyer Module for $999. If you already own either module you will automatically have access to NDI when you install the latest updates.

You can read more about this new feature in this knowledge base article.


Read more »



Apr
16
Info on ProPresenter and QuickTime and the recommendation to remove QuickTime
Posted by Renewed Vision on April 16, 2016 at 04:41 PM

If you've been keeping up with any tech news over the last few days you've likely seen a number of articles suggesting you immediately remove QuickTime. Computer security company Trend Micro has reported that Apple is ending support for QuickTime for Windows despite there being some known vulnerabilities in QuickTime. These vulnerabilities have been known for a while and Trend Micro has reported that they've seen no evidence of these vulnerabilities being exploited. Both vulernabilities require a user to visit an infected site and/or install an infected file, but again, it doesn't appear that either of these vulnerabilities are being exploited. As of the published date of this article QuickTime is still available for download from Apple and there is no official statement from Apple available. Apple has updated their support article about QuickTime indicating that it is no longer being updated.

If you are using ProPresenter 6 then you no longer need QuickTime. We rebuilt our render engine to be fully self-contained and not rely on third-party software like QuickTime. If you are still using ProPresenter 4 or ProPresenter 5 then you need QuickTime to be installed on your computer for ProPresenter to function correctly. You can upgrade to ProPresenter 6 at any time, although discounts for ProPresenter 4 users to upgrade are no longer available.

Keep in mind that many other programs such as After Effects for Windows also rely on QuickTime to run correctly. If you choose to uninstall QuickTime verify that you aren't running any programs that need it to be installed to work correctly.

If you want to uninstall QuickTime, here is the link to Apple's official instructions.

ProPresenter 4 and ProPresenter 5 may not work properly without QuickTime being installed on your computer. Both of thse versions will still be able to play WMV or MPEG videos, but they will not be able to play QuickTime files (MOV or MP4). If you want to uninstall QuickTime, you can replace it with the free QuickTime Alternative. Click here to go directly to the download page for QuickTime Alternative. You wll want to use the first link to download QuickTime Alternative 3.2.2. You may see some warnings or alerts about the download, but codecs.com is a safe site. Click through the installer until you get to the Select Compontents screen. You do not need to check the box for Media Player Classic. The default Normal option will work. Click through the remaining screens without changing anything. After QuickTime Alternative is installed, click Finish on the final screen. You should now be able to use QuickTime videos in ProPresenter 4 and ProPresenter 5. This has only been verified to work with Windows 7. If you are using Windows 8.1 or Windows 10, we recommend keeping QuickTime or upgrading to ProPresenter 6.


Read more »